| Check the chart below for solutions to common problems.
Need more help?
Check
out the Frequently Asked Questions page.
|
Symptom:
Parts/accessories
missing… |
|
Possible
Cause(s):
1. Packed in tank |
 |
Corrective
Action:
1. Check in tank |
|
Symptom:
Vacuum cleaner
will
not start… |
|
Possible
Cause(s):
1. Defective switch or defective
motor
2. Note: OnDemandVacs (925-63, 925-64 and 925-65)
The vacuum circuit breaker
button out or no continuity |
 |
Corrective
Action:
1. Contact Customer
Service at 570-326-3557 or submit a help request.
2. Push circuit breaker; If that does not solve the problem,
contact Customer Service at 570-326-3557 or submit
a help request. |
|
Symptom:
Dust discharging
from exhaust… |
|
Possible
Cause(s):
1. Filter not installed
2. Filter damaged
3. Filter clogged or dust is too fine
4. Filter not functional |
 |
Corrective
Action:
1. Properly install filter
2. Replace filter
3. Use more efficient filter
4. Clean or replace filter |
|
Symptom:
Loss of suction… |
|
Possible
Cause(s):
1. Loose hose connection
2. Filter clogged
3. Full tank
4. Hole in hose |
 |
Corrective
Action:
1. Tighten hose connection
2. Clean or replace filter
3. Empty tank
4. Replace hose |
|
Symptom:
Static shock… |
|
Possible
Cause(s):
1. Dry environment
2. Relative humidity of air is low |
 |
Corrective
Action:
1. Add moisture to air (if
practical, use a console or installed humidifier)
2. This situation is temporary and does not affect the use of the vacuum cleaner |
|
Keep Connected with Shop-Vac
For Tips & Tricks, Promotions and News


